Status of wi(4)

From: Erwin Lansing (erwin_at_FreeBSD.org)
Date: 12/08/03

  • Next message: Craig Boston: "Re: dev/em: Link is not up until 2 seconds after "ifconfig up""
    Date: Mon, 8 Dec 2003 17:26:37 +0100
    To: current@FreeBSD.org
    
    
    

    Some time ago, I've seen some traffic about problems with wi(4). I've
    been on holiday for most of November, just to find my fine working
    Netgear MA401 no longer functional on 5.2-RC. AFAIKS initialization
    fails (see below). Are there still known oustanding issues with wi ?

    -erwin

    wi0: <NETGEAR MA401 Wireless PC Card> at port 0x100-0x13f irq 11
    function 0 config 1 on pccard0
    wi0: 801.11 address: 00:30:ab:11:69:a5
    wi0: using RF:PRISM2 MAC:HFA3841 CARD:HWB3163 rev.A
    wi0: Intersil Firmware: Primary (0.3.0), Station (0.8.3)
    wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
    wi0: timeout in wi_cmd 0x0002; event status 0x0008
    wi0: timeout in wi_cmd 0x0000; event status 0x0008
    wi0: wi_cmd: busy bit won't clear.
    wi0: init failed
    wi0: failed to allocate 2372 bytes on NIC
    wi0: tx buffer allocation failed (error 12)
    wi0: interface not running

    -- 
                        _._     _,-'""`-._
    Erwin Lansing      (,-.`._,'(       |\`-/|    erwin@lansing.dk
    http://droso.org       `-.-' \ )-`( , o o)    erwin@FreeBSD.org
                        -bf-      `-    \`_`"'-
    
    



  • Next message: Craig Boston: "Re: dev/em: Link is not up until 2 seconds after "ifconfig up""

    Relevant Pages

    • Problem with wi in CURRENT (and 5.1)
      ... pci0: <PCI bus> on pcib0 ... pci_cfgintr: 0:29 INTA BIOS irq 11 ... wi0: ... timeout in wi_cmd 0x0002; ...
      (freebsd-current)
    • troubles with recent wireless changes
      ... After january changes in wireless area I've encountered several problems ... wi0: timeout in wi_cmd 0x010b; ... dstumbler doesn't work anymore due to the ...
      (freebsd-current)
    • acpi, wi0 and apm.
      ... It works fine when I boot my FreeBSD 5.4-RC3 with acpi disabled. ... wi0: timeout in wi_cmd 0x0000; ... But i've compiled device apm into the kernel but I don't have ...
      (freebsd-questions)
    • Fwd: Belkin wireless network card problem
      ... I have about 10 days left to return this card if I cannot get it to work. ... wi0: timeout in wi_cmd 0x0000; ... My other computer is your windows box. ...
      (freebsd-questions)
    • Belkin wireless network card problem
      ... I finally got a wireless kit. ... the Belkin card is giving this ... wi0: timeout in wi_cmd 0x0000; ...
      (freebsd-questions)