Re: wireless on a laptop



On Fri, 24 Feb 2006 08:30:36 +0100
Florent Thoumie <flz@xxxxxxxx> wrote:

On Thursday 23 February 2006 17:40, Chuck Lever wrote:
hi all-

i have a D-Link DWL-G650M PCCard (Atheros) and an IBM T40 laptop. they
don't want to talk with each other.

the T40 has a built in Aironet, but the driver generates "received 194
bytes, expected 196 bytes" messages in the system log, and i can't get
it to work.

so i bought this Atheros-based super-G card.

the problem is the cardbus infrastructure doesn't seem to recognize the
card. even if i "kldload if_ath".

i'm new to FreeBSD, so any guidance here would be greatly appreciated.

Atheros Super-G cards are not (yet?) supported.

I think your best bet is to use ndis(4) (see ndisgen(8)).

--
Florent Thoumie
flz@xxxxxxxxxxx
FreeBSD Committer
Greetings,

I use a D-Link DWL-G650B2/TP600E combo under FreeBSD 6 with the ath driver and get
G+ speeds, but only when I'm connecting to my D-Link AP, though.

Note, it is not enough to just do a "kldload if_ath", you have to load the HAL
("kldload ath_hal" and then load the primary driver. Do a "man ath" for the
details.

GClarkII

--
GB Clark II | Roaming FreeBSD Admin
gclarkii@xxxxxxxxxxxxxx | General Geek
CTHULU for President - Why choose the lesser of two evils?
_______________________________________________
freebsd-hackers@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-hackers
To unsubscribe, send any mail to "freebsd-hackers-unsubscribe@xxxxxxxxxxx"