Re: dummynet, em driver, device polling issues :-((

From: Kevin Day (toasty_at_dragondata.com)
Date: 10/04/05

  • Next message: Marcin Jessa: "Re: How connect 2 PC with ath in hostap mode ?"
    Date: Tue, 4 Oct 2005 07:45:08 -0500
    To: ferdinand.goldmann@jku.at
    
    

    On Oct 4, 2005, at 7:00 AM, Ferdinand Goldmann wrote:
    >
    > Ok, to followup on this issue:
    >
    > Today I installed the driver which I had downloaded from the Intel
    > website (em-3.2.15.tar.gz). This driver does not solve the issue
    > with Ierrs rising rapidly when polling is enabled (I tried HZ=1000
    > and burst_max 300 and 600).
    >
    > Neither throughput nor interrupt load were any better than with the
    > old driver; in fact I'd say they were worse. :-( So we ended up
    > rebooting with the old kernel.
    >
    > This is pretty bad, because we did assume that Intel cards are
    > among the ones well supported by FreeBSD.
    >
    > Can anyone give recommendations on copper Gbit cards that work
    > _well_ with recent FreeBSD 5-STABLE?

    This is pretty odd. We've got dozens of servers using various
    versions of 5.x, and many different em cards, and have no problem,
    even when shoving near line rate speeds out of them.

    Add in cards like:

    em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port
    0xccc0-0xccff mem 0xfcd20000-0xfcd3ffff irq 24 at device 6.0 on pci2

    and built in to newer Dell servers:

    em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port
    0xecc0-0xecff mem 0xdfae0000-0xdfafffff irq 64 at device 7.0 on pci6

    After you experience your problems, can you do "sysctl -w
    hw.em0.stats=1" and "sysctl -w hw.em0.debug_info=1" and post what
    gets dumped to your syslog/dmesg output?

    We're using polling on nearly all the servers, and don't see ierrs at
    all. Have you tried contacting Intel directly about this?
    freebsdnic@mailbox.intel.com has been pretty helpful with em specific
    problems in the past.

    _______________________________________________
    freebsd-net@freebsd.org mailing list
    http://lists.freebsd.org/mailman/listinfo/freebsd-net
    To unsubscribe, send any mail to "freebsd-net-unsubscribe@freebsd.org"


  • Next message: Marcin Jessa: "Re: How connect 2 PC with ath in hostap mode ?"

    Relevant Pages

    • Re: VGA cards
      ... but people may need some functions that are not provided by Intel ... And remember that Intel driver also had its own glitches... ... So ATI are another brand, ... overall hassle is generally far less on using Intel cards. ...
      (Debian-User)
    • Re: xorg.conf no longer changeabe by system-config-display
      ... I have an IBM T43 with the Intel 915 chipset running FC5. ... I tried and tried to configure dual head operation several times and with several different pci secondary video cards without much progress. ... This was on a computer with an Intel 815 built into the main board. ... 915GM chipset, but the screen is not updated correctly when I set up X to use the i815 driver, although it worked fine in FC4. ...
      (Fedora)
    • Re: Intel EtherExpress Pro/100 connection freezing
      ... > On some M$ servers I look after I saw the same thing with Intel PRO/100 ... In any event, Intel state that their driver is only for 2.4.x kernels, ... don't the card manufacturers include _both_ lengths of bracket with their ...
      (comp.os.linux.networking)
    • Re: FreeBSD 8.0 ixgbe Poor Performance
      ... I believe that "pciconf -lvc" showed that the cards were in the correct ... the latest driver needs to be built in a FreeBSD STABLE tree. ... The default driver config ... >>> Intel S5000PAL Motherboard ...
      (freebsd-performance)
    • Supported videocards?
      ... I just installed Mce 2005 and it says "videocard or driver not supported". ... Im using a motherboard with intel 865g chipset and the build in "Intel ... Is there a place where I can find what cards are supported? ...
      (microsoft.public.windows.mediacenter)