Re: Raising temperature threshold



On Wed, Jun 22, 2005 at 01:52:22PM -0300, Matthew Flanagan wrote:
> On 22 Jun 2005 11:46:31 -0400, Lowell Gilbert
> <freebsd-questions-local@xxxxxxxxxxxxxxx> wrote:
> > Matthew Flanagan <flanagan.matt@xxxxxxxxx> writes:
> >
> > > I`ve installed a FreeBSD 5.4-STABLE and I was building some ports when
> > > suddenly my system shut down. Upon rebooting it and checking
> > > /var/log/messages, I found the following lines:
> > >
> > > Jun 21 16:01:30 bell root: WARNING: system temperature too high,
> > > shutting down soon!
> > > Jun 21 16:01:40 bell kernel: acpi_tz0: WARNING - current temperature
> > > (60.0C) exceeds safe limits
> > >
> > > Then I realized what had happened. My acpi_thermal sysctl's are:
> > >
> > > hw.acpi.thermal.min_runtime: 0
> > > hw.acpi.thermal.polling_rate: 10
> > > hw.acpi.thermal.tz0.temperature: 50.0C
> > > hw.acpi.thermal.tz0.active: 0
> > > hw.acpi.thermal.tz0.thermal_flags: 1
> > > hw.acpi.thermal.tz0._PSV: 50.0C
> > > hw.acpi.thermal.tz0._HOT: -1
> > > hw.acpi.thermal.tz0._CRT: 60.0C
> > > hw.acpi.thermal.tz0._ACx: 50.0C -1 -1 -1 -1 -1 -1 -1 -1 -1
> > >
> > > When I try to raise hw.acpi.thermal.tz0._CRT to 85C (which is the
> > threshold in
> > > the BIOS setup) it doesn't work:
> > >
> > > bell# sysctl hw.acpi.thermal.tz0._CRT=3580 # 3580 tenths of Kelvin=85C
> > > sysctl: oid 'hw.acpi.thermal.tz0._CRT' is read only
> > >
> > > I've tried /etc/sysctl.conf as well, but I get the same error.
> > >
> > > Now, my question is: how do I change this value? I've read several
> > manpages
> > > (acpi(4), acpi_thermal(4), acpiconf(8), and many others) and checked the
> > > handbook, to no avail. Can anyone point me to the right direction?
> >
> > Can it be set at boot time? [from the loader?]
>
> Perhaps, but loader(8) lists the kernel tunable parameters available, and
> hw.acpi.thermal.tz%d._CRT isn't one of them.

Did you ever discover a resolution to this? I have a Shuttle SN95G5
system that is doing the same thing. To make matters worse, it appears
that the hw.acpi.thermal.tz0.temperature value that is being returned is
5 to 10 degrees higher than what BIOS thinks (I am inclined to believe
the BIOS on this one). I can change the CPU fan speed settings in the
BIOS. It has pretty extensive control of this, with the default setting
of "SMART FAN" where it controls fan speed based on CPU temperature.
Unfortunately, in that mode the hw.acpi.thermal.tz0.temperature slews to
60C (while BIOS reads below 50C) before the fan has sped up enough. I
can also set the fan speed control to fixed, relatively higher values,
but the fan noise is then bothersome.

So, anyone know where the 60C value for hw.acpi.thermal.tz0._CRT is
derived from and how to change it?

Thanks,
Bob


>
> Cheers,
> Matt
> _______________________________________________
> freebsd-questions@xxxxxxxxxxx mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"

--
Bob Willcox Maintainer's Motto:
bob@xxxxxxxxxx If we can't fix it, it ain't broke.
Austin, TX
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"