OpenSSH Problem with disconnects





Hi,



I am having a big problem with the OpenSSH Daemon on my server. Whenever I
am connected to the server and the connection is idle for a few seconds it
gets disconnected. It's almost impossible to work from remote on the server
when the connection is always getting dropped. The server is running FreeBSD
angmar.domain.com 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30
UTC 2007 root@xxxxxxxxxxxxxxxxxxxxxxx:/usr/obj/usr/src/sys/SMP i386 and
the SSHD installed by sysinstall OpenSSH_4.5p1 FreeBSD-20061110, OpenSSL
0.9.7e-p1 25 Oct 2004 . I tried a complete FreeBSD reinstall but it did not
help, I tried various settings like KeepAlive TCPKeepAlive but they did not
help either. I upgraded OpenSSL to 0.9.8e and I installed OpenSSH 4.6p1 but
it did not solve the problem. When I run SSH with loglevel debug I see this
in the auth.log when I am getting disconnected: Read error from remote host
192.168.2.100: Connection reset by peer . When I use strace to monitor the
process I see this on disconnect



643 wait4(-1, [WIFEXITED(s) && WEXITSTATUS(s) == 0], WNOHANG, NULL) = 4975

643 wait4(-1, 0xbfbfdc9c, WNOHANG, NULL) = -1 ECHILD (No child processes)

643 syscall_416(0x14, 0, 0xbfbfdc20) = 0

643 syscall_417(0xbfbfdcd0) = -1 (errno 4)

643 select(7, [3 4], NULL, NULL, NULL <unfinished ...>



I tried to find information's about syscall_417 but had no luck with that. I
am stuck here and have no idea what to do. When I am connected to the server
by FTP I don't get disconnected when the connection is idle ( no nohup or so
being sent ) and when I connect by Telnet I also don't get disconnected when
the connection is idle. I am not sure if I should add the dmesg output here
for sys specs or not. I don't do it now but can give it if needed.



I installed Debian on another HDD of the server today and I am not having
any problems there. No SSH disconnects all the time. Thanks for any help.



-Alex



_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: Socket
    ... When you disconnect, TCP detects that the connection was broken. ... i used to sent pong to server when server pinged ... Now on client side when client recived ...
    (microsoft.public.dotnet.faqs)
  • Re: Socket
    ... When you disconnect, TCP detects that the connection was broken. ... i used to sent pong to server when server pinged ... Now on client side when client recived ...
    (microsoft.public.dotnet.languages.vb)
  • Re: Socket
    ... When you disconnect, TCP detects that the connection was broken. ... i used to sent pong to server when server pinged ... Now on client side when client recived ...
    (microsoft.public.dotnet.general)
  • Re: why dataset in ado.net is disconnected
    ... need to be able to support thousands of concurrent users on a server ... application - all interacting with the database in a real-time mode. ... Either maintain an open connection all the time. ... possible and to encourage you to disconnect as soon as possible - for the ...
    (microsoft.public.dotnet.framework.adonet)
  • Re: 2 SSH questions: why does it pause so much, and, can I keep connection alive?
    ... >I believe the server is behind a firewall. ... When a packet arrives, its source IP, ... then the connection is added to the state table. ... > Iım running OpenSSH 3.6.1 on Mac OSX. ...
    (comp.security.ssh)