Re: php5-5.2.3_1 / website behaves as if not enabled in httpd.conf



Dear Ian and others,

2007/9/12, Ian Smith <smithi@xxxxxxxxxxxxx>:
On Wed, 12 Sep 2007 09:23:19 +0200 Zbigniew Szalbot wrote:
> 2007/9/12, Ian Smith <smithi@xxxxxxxxxxxxx>:
> > On Tue, 11 Sep 2007 19:19:32 +0200 Zbigniew Szalbot wrote:
[..]
> No, it wasn't in there but I moved it to this section. There is no
> difference. I cannot start apache.
[..]
> > And check that /usr/local/libexec/apache/libphp5.so exists!
>
> Everything is fine here. But I think now that the problem is not with
> apache but with php. It does not even matter if I do start or
> startssl. In both instances the httpd server dies. The reason I think
> it is php-related is that when I issue php -v I get:
>
> PHP 5.2.3 with Suhosin-Patch 0.9.6.2 (cli) (built: Sep 12 2007 08:59:52)
> Copyright (c) 1997-2007 The PHP Group
> Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
> Segmentation fault (core dumped)

Well it's broken for sure if php -v dumps .. and if php cli is broken
most likely the module is too, which may well explain apache crashing ..

> pkg_info | grep php5
> php5-5.2.3_1 PHP Scripting Language (Apache Module and CLI)
>
> I do not really feel like upgrading apache (as suggested by someone
> else - thank you by the way) because it is just a home machine on
> which I do not need all the greatest and latest.
>
> If there's nothing obvious that comes to your mind I will try posting
> it on a php list.

Sorry, I'm on digests here which can take half a day unless you cc me,
so I hope you've made some progress by now .. no, nothing obvious, but:

I'd be trying to separate these two problems: save configs, comment out
all of the php stuff in httpd.conf and get your upgraded apache up and
running properly first, then refetch / reinstall / reconfigure php5?

I commented out all extensions and then brought them in one by one.
The one which was causing core dumps was simplexml.so. I had a few
others that I had to comment as otherwise they were giving me trouble
(because of the simplexml being commented out I guess): pdo.so,
pdo_sqlite.so, spl.so, mysqli.so, sqlite.so.

I am not really worried about these. I am not really sure if I will
ever need them. So fine for the time being. php -v does not produce
core dumps and I can start apache.

There's only one problem left to be solved - files with php extensions
are not really shown in browser until I click RELOAD. Files with html
extensions are shown without the need to reload. Thanks for your
patience!

Zbigniew Szalbot
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: no apache22, php5 cores
    ... If apache works then it is just a php problem. ... 9/10 the php problem is just the extensions dependencies problem. ...
    (freebsd-questions)
  • Help with php5 install under windows
    ... This includes moving php from the ... Enable the PHP scripting language engine under Apache. ... or per-virtualhost web server configuration file. ... The PHP directives register_globals, ...
    (php.general)
  • Re: [Full-disclosure] Bug with .php extension?
    ... the behavior that is i.e. demonstrated on default installations of Apache, only that this time not mod_negotiation, but mod_mime is responsible. ... Unknown extensions contribute nothing, and since they're unknown, it isn't known which category they aren't known for, so nothing happens with them. ... - Disable PHP for the upload area (is this possible? ... you would want your user upload area to be in a totally different place from your DocumentRoot so you don't get anything set on DocumentRoot leaking into the writable subdirectory. ...
    (Full-Disclosure)
  • Re: Cant load extensions: "The specified module could not be found"
    ... I get the same problem with some other extensions as well -- not just cURL. ... These give the same error message (apart from the DLL name of course). ... I know that, generally, PHP *can* see the DLLs in the extensions folder. ... I'm running Apache 2 with PHP 4.4.6 on Windows XP. ...
    (alt.php)
  • Re: [Full-disclosure] Apache suEXEC privilege elevation / information disclosure
    ... The suEXEC feature provides Apache users the ability to run CGI and SSI ... under user IDs different from the user ID of the calling web server. ... Normally php and cgi scripts are not allowed to read files with the ... because the php script is run trough suEXEC. ...
    (Bugtraq)