Re: Override ports security restrictions?



On 9/25/07, Tim DeBoer <tdeboer@xxxxxxxxx> wrote:
[snip]
Hmmm, it seems to want to work, but I end up with a bunch of errors.

# make -DIGNORE_VULNERABILITIES install
"/usr/ports/Mk/bsd.port.mk", line 2294: warning: String co
mparison operator should be either == or !=
"/usr/ports/Mk/bsd.port.mk", line 2294: warning: String co
mparison operator should be either == or !=
"/usr/ports/Mk/bsd.port.mk", line 2294: Malformed conditio
nal (((${OSVERSION} < 504105 || (${OSVERSION} >= 600000 &&
${OSVERSION} < 600103) || (${OSVERSION} >= 700000 && ${OS
VERSION} < 700012)) && ${PKGORIGIN} != "ports-mgmt/pkg_ins
tall") || exists(${LOCALBASE}/sbin/pkg_info))
"/usr/ports/Mk/bsd.port.mk", line 2295: warning: String co
mparison operator should be either == or !=
"/usr/ports/Mk/bsd.port.mk", line 2295: warning: String co
mparison operator should be either == or !=
"/usr/ports/Mk/bsd.port.mk", line 2295: Malformed conditio
nal ((${OSVERSION} < 504105 || (${OSVERSION} >= 600000 &&
${OSVERSION} < 600103) || (${OSVERSION} >= 700000 && ${OSV
ERSION} < 700012)) && ${PKGORIGIN} != "ports-mgmt/pkg_inst
all")
"/usr/ports/Mk/bsd.port.mk", line 6100: if-less endif
"/usr/ports/Mk/bsd.port.mk", line 6100: Need an operator
"/usr/ports/Mk/bsd.port.mk", line 6103: if-less endif
"/usr/ports/Mk/bsd.port.mk", line 6103: Need an operator
make: fatal errors encountered -- cannot continue

Any thoughts?

Thanks, I really do appreciate the help :-)

Never mind that. I'm an idiot.
I was trying to build on the machine I'm going to replace.
Observation skills FTW.

make DISABLE_VULNERABILITIES=yes install

Did the trick.

Thanks for the help!

--
Tim DeBoer
http://www.freebsd-geek.com
Just once, I'd like it if someone called me "Sir".
Without adding "You're creating a scene".
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"