Re: flash9 checklist

On Thursday 30 October 2008 19:53:33 Juergen Lock wrote:
In article <49086F1A.2090500@xxxxxxxxxxx> you write:
Juergen Lock wrote:
Preliminary checklist for getting flash9 to work in native firefox:
(flash10 needs more ports work, I shall post about that seperately on
-emulation...) If you have additions to this please post a followup to
this thread, keeping the Cc: (I'm not on -questions...)

1. You need RELENG_7 from at least Mon Oct 20 11:15:57 2008 UTC
(the relevant MFC commits are:
- a recent HEAD should also work of course.) There are linprocfs
patches for RELENG_6 too (merging the former commit), but the latter
commit can't be merged to 6 (and 7.0) since they lack the cpuset bits,
so flash9 probably won't work on SMP there. (Although if you have SMP
you probably should be running 7 anyway. :) Oh and if you do have SMP
you also need to use the ULE scheduler, the cpuset syscalls are not
supported with 4BSD. linprocfs patches for 6:

2. Your portstree needs to be from at least Sun Oct 19 17:37:28 2008 UTC
(the last www/linux-flashplugin9 commit is:

3. Make sure linprocfs is mounted to /compat/linux/proc .

4. Make sure www/nspluginwrapper, www/linux-flashplugin9 and
dependencies are installed and up to date(!). (the default
emulators/linux_base-fc4 should work, if you want to use a later one
don't forget to set compat.linux.osrelease=2.6.16 in sysctl.conf and
OVERRIDE_LINUX_BASE_PORT to whichever version you use in make.conf.
Note however that on 6, only the default compat.linux.osrelease=2.4.2
really works.)

5. If the plugin doesnt show up in firefox' about:plugins, run
nspluginwrapper -i
/usr/local/lib/npapi/linux-flashplugin/ and restart

6. And remember there's a security advisory for the current version of
0016.html (if you use portaudit you need to `make
-DDISABLE_VULNERABILITIES ...' to be able to install the port), and fc4
seems to be eol'd too, so you probably want to install something like
the noscript firefox extension,
and only allow plugins (and scripts, tho thats a different problem) on
sites you trust...

And finally, if you still get crashes after following the above even
on pages that are reported to work now (like youtube) you probably want
to run `ktrace -di firefox...' and look at the output using linux_kdump
(thats the devel/linux_kdump port, you want to use a package), paying
specific attention to the lines above `PSIG SIGSEGV' (or whichever
signal you got), maybe there are still shlibs missing that the plugin
needs (NAMI, and if this is the case tell us about
it so the appropriate dependencies can be added to the relevant ports.
If you can't figure it out I guess it doesn't hurt to post the last
few 100 lines of the dump up to the relevant PSIG on -emulation...

You may also want to check linked shlibs like this:
/compat/linux/bin/sh /compat/linux/usr/bin/ldd
/usr/local/lib/npapi/linux-flashplugin/ and
/compat/linux/bin/sh /compat/linux/usr/bin/ldd
/usr/local/lib/nspluginwrapper/i386/linux/npviewer.bin (if you see `not
found' in there you know something is wrong) - although that doesn't
show libs that may be dlopen()d at runtime.

Thanks for this. I was able to get linux-flashplugin9 working in native
Firefox 3.0.3 on FreeBSD 7-STABLE i386. The only additional thing I had
to do was copy
/usr/X11R6/lib/browser_plugins/ into
~/.mozilla/plugins/ for Firefox to recognize the plugin.

Yeah I forgot to note that you want to run nspluginwrapper -i
as the user that will run the native browser, not as root, then the
wrapper will go into ~/.mozilla/plugins/...

After that
Youtube, google video, and google maps (incl. street view) work fine,
but slow. A friend of mine with a very similar setup was not so lucky
and still has problems with flash9 locking up FF.

Hmm, lockups I haven't seen yet here.

freebsd-questions@xxxxxxxxxxx mailing list
To unsubscribe, send any mail to

It works almost perfectly for me ! Thanks for this, Juergen !.

I had to say "almost perfectly" because in myspace, for instance, it takes a
while for the "flashies" to start. One thing I noticed is that if I terminate
FF, npviewer.bin remains loaded and I have to kill it.

Here is what I've got:

CPU: Intel(R) Pentium(R) D CPU 3.20GHz (3199.66-MHz 686-class CPU)
real memory = 2146304000 (2046 MB)
nvidia0: <GeForce 7100 GS> on vgapci0
FreeBSD 7.1-PRERELEASE #3: Wed Oct 29 18:37:07 BRT 2008 (i386)

kern.ipc.shmmax: 33554432 -> 1036870912
kern.ipc.shmall: 8192 -> 261072
compat.linux.osrelease: 2.4.2 -> 2.6.16

firefox-3.0.3,1 AND (both work!)

The mtv site worked fine all the way !! Great oldie stuff !

Mario Lobo
FreeBSD since version 2.2.8 [not Pro-Audio.... YET!!] (99,7% winedows FREE)
freebsd-questions@xxxxxxxxxxx mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"