Re: boot sector f*ed



Roland Smith wrote:
On Thu, Aug 13, 2009 at 09:53:06AM -0400, PJ wrote:

I apologize for the lengthy explanation below, but perhaps it will give
some insight on what is see from this end:

Ok, I've had all night to (subliminally) think about all this and
actually, I am tending more toward problems in FreeBSD... (this is not
an apology or a defense of my lack of knowledge or capacities, just a
clarification so you know what kind of a dummy you're dealing with)
First, let me explain that everything that we have been talking about -
the recovery methods, installation, hardware problems, etc. are all
extremely, and I mean extremely, subject to an awful lot of variables.


I don't understand?

I must confess that I find your explanations sometimes a bit vague. You're
sitting in front of the machine with the problems. We (on the mailing list)
see only what you say. It is difficult for me at least to piece together what
exactly happened.

If you are reporting errors, try to be as specific as possible. E.g. don't say
"I updated the machine and it doesn't boot anymore". Start with something like:
"After running freebsd-update with the options blabla" or "after updating the
machine from the 7.2 CD making the following choices...". And then say "I got
stuck in the FreeBSD logo screen", or "I got stuck on a screen showing the
lines 'Default: 0:ad(0,a)/boot/loader' and 'boot:'". That gives us at
least a chance to see what has gone wrong.

I must say that I have never used the method of updating from CD. I tend to
update the system sources with csup(8), and then rebuild the kernel and
applications from source as explained in the Handbook. This hase never failed
me yet.


1. Reporting the errors is a little difficult because more often than
not, the errors fly by too fast to be fully understandable.

2. I usually and never (since way, way back) do not update from a CD,
except to boot up; I do the rest over ftp from the main source at
freebsd.org. and I use cvsup-without-gui. :-)
Therefore, determining what exactly has or is going wrong is almost a
complete impossibility. Let me explain and you will get an idea of what
I mean (and of the difficulties I am facing).

<snip>

The troubles began when I tried to install flashplayer on the
7.1 machine.


I guess I missed that? Can't remember.


At the same time I did manage to arrange my daughters
portable Acer Travelmate 4400 running on AMD Turion 64bit; it was a low
end snail paced horrow with XP so I got rid of that in installed FBSD
64bit and got it work just fine with X Windows, Firefox and even
flashplayer under Linux emulation. This was a few weeks ago... it's
still running fine.



But upgrading to 7.2 and installing flashplayer was pretty much an
impossibility on both of my machines - after extremely time-consuming
(easily several days of long waits for compilation) setups, installs,
reinstallsand portupgrades, all the programs I need finally came
together in a very satisfying configuration. What I needed - Samba,
apache22, php5.1, mysql, phpMyAdmin, Xorg, java, firefox, flashplayer,
cups, NetBeans and Openoffice.org along with a few small proggies like
bash4 and fluxbox for X. Everything seemed to work fine. I ran all the
programs and saw that all the files I had recovered from the crash were
recovered and working. Man, was I ever happy!
I shut down for the night and looked forward to getting bask to normal
development of my current projects.
In the morning, I boot up and WHAM!... the system is f**cked. And so am I.


Did you use 'nextboot' by any chance?

Don't know what that is; never heard of it, thus never used it.

Now, the problem is that it is imperative to be able to figure out what
exactly is going on. Well, the problem with that is that I do not seem
to be in a position to do what is required.



For one thing, I do not know how I can save testing output to an external
file when I am working on a temporary shell on the problem machine. Perhaps
you could indicate what I should be doing or where to look for information.


Insert a USB thumbdrive and mount it. Copy the files to it, unmount. The
GENERIC kernel on the CD should have all the necessary drivers for this to work.
Assuming that you're logged in as root, and that your USB drive is recognized
as /dev/da0s1:

mkdir /usbdrive
mount_msdosfs -m 644 -M 755 -l -o noatime -o sync /dev/da0s1 /usbdrive
# copy the files you need...
umount /usbdrive

I'll try that; oddly, I was able to use my SanDisk 4gb cruzer before.
Chuck it into usb, mount /dev/cd0 to /mnt and go to it. But now, for
some strange reason it just wont mount. I'm getting messages that it's
not readable - "g_vfs_done input output error" and attempt to query
device size failed, medium may have changed. But the stick is fully
insertable, readable, removable from XP; as it was on FBSD. Weird.

Another problem is rather a strange quirk or I don't know what - The
problems I am having are on two very similar machines: 1 is a MSI 6758
875P NeoFisr motherboard running on a Pentium 3.0ghz CPU; the other is
the identical board with a Pentium 2.4ghz CPU. The strange thing is that
even with identical bios, the bios does not act the same on both
machines.


I don't understand what you mean by that? What do you mean by "doesn't act the
same"?


When turning on the computer, hit del and the bios setup comes on almost
immediately on the 3ghz machine. On the 2.4 machine it takes much, much
longer to start up (the monitor is Hitachi superScan Elite 812 on the
3ghz machine, hitachi CM751 on the 2.4ghz) and when del is pressed the
bios goes through the entire scanniing process and then restarts before
finally going into the bios... and the versions of the bios and the
setup are both identical in nubers but, if I recall correctly, there are
some minor differences in some of the more arcane options that I never
even look at. And in general it always ran a bit sluggish.
The final install that was so promising was on the 2.4 ghz
machine. Except for being somewhat slower (I find it rather slow
compared to the the 3ghz, but maybe that's normal) it always worked
without problems.


CPU speed is not the only factor, and probably not the dominating factor in
overall performance. The speed of the RAM and especially the harddisk(s) can
have a much larger inpact because they are several orders of magnitude slower
than the CPU.


And in checking the disks with fdisk, fsck, and even running that weird
regenerate progam... I wasn't able to come up with anything


Please capture the output from running fdisk and bsdlabel on the problem disk
and post it here. Maybe we can see something that didn't catch your eye.


significant... that is, the configuration of the disks seemed to be ok,
the boot sector was ok as it was able to boot but the when the system
was being mounted something went wrong... and looking back, I vaguely
recall something about a "soft update" or something like that which
seems to indicate some stumbling block in the software and not hardware.


Soft updates is a technique employed by the filesystem to ensure that the file
system stays consistent. See ffs(7): 'man 7 ffs'. And "something went wrong"
and "I vaguely recall something about soft update" is not a lot for us to go on...

You know that you can use 'dmesg|less' to recall messages that the kernel put
out? Or use 'tail -n 100 /var/log/messages|less'.


Now there a a couple of weird symptoms that don't make any sense to me
anyway - I tried booting a minimal installation on the 2.4ghz machine
from a disk that was set up before the crashed disk was installed and
that boot did not work... there was no reason for it to not work...


If it doesn't boot there is a reason for it. But without information as to
what _exactly_ you did to make it boot from that disk, and what happened (as
in did what did you see the different boot screens) nobody can tell you what
happened.


all it had was a functioning samba and bash4 with cvsup-without-gui and it
worked fine for checking and recovering files from the other disks both on
the machine and through usb.


You don't need cvsup-without-gui anymore. A new utility written in C called
csup is part of the base system since 6.2, I believe.


All that I am seeing is that there is either a problem with the bios
(which I even reinstalled and that changed nothing in the functioning)
or something is going on with the OS.
I must say, it is weird that with FBSD 7.2 things have not been going
well at all...


I don't want to be rude, but you could have made a mistake somewhere. If
you're futzing around with disks and partitions it is quite easy to screw
something up. Even for people with lots of experience it is sometimes a case
of PEBKAC. :-)


I understand what you are saying and I don't take it to be rude at
all... actually, I don't screw around with the disks and the
partitions... I only try to read them to recover any files I may have
lost. So far, I have had 100% success on recovering lost data that was
important.
Up to now, when I had problems with crashes, I just reinstalled
everything, the OS, the programs loaded up the files that were recoverd
and whoopie... keep on chugging along. I did exactly that on this last
great effort - actually, it took a great deal of patience and
application to install the 64bit FBSD with flashplugin on the portable
and it took extreme patience to wait for all the updates and upgrades
and the searching and figuring out just how to configure and set up the
i386 on the 2.4ghz machine - and it all worked beautifully; I was really
happy that my ordeal was over and now I could get on with it. Not a nice
way to wake up in the morning with the box sputtering out ...
No, do not "futz around" - I have been doing my updates with portupgrade
- compilin the ports is long and terribly boring - that's usually when I
can write long e-mails ;-) and now I'm trying portmaster - but it is
giving me a bit of heartburn - it seems to stumble over itself - the
updates dont work too well. It seems, that when the updates span several
releases, portmaster does not know what it's doing - I caught it
upgrading to an older version when it aborted; and the dependencies seem
to suffer from the same kind of behavious. Make deinstall, make
reinstall seems to be the best way... and then sit there and watch the
screen expecting to suddenly have the compiling be interrruptted by the
configuration scree. And that is often a pain... there are so many
options that mostly have no direct meaning for me of use, for that
matter. For example, ghostscript - do I really need it? I'm only using 1
printer and that is a postscript Xerox Phaser 8200 that has no driver in
the ghostscript files. And the same for gutenberg... and other
dependencies - I suppose that some are needed for various
implementations of different programs that call them... but that should
really be default settings. And who uses the the new ipv6 stuff?

I now have set up another instance of 7.2 on a different disk on the
2.4ghz machine and I already find something strange... after installing
the minimum configuration, I installed the packages - samba3.3.3,
cvsup-without-gui, and smartmontools. I tried to run smartctl and cvsup
but nothing worked. The path variable was correct but the shell just
would not pick up on it. I had to start the programs from their directories.
That just doesn't make sense.


That is not a mystery. The default FreeBSD shell, tcsh, doesn't pick up new
programs automatically (for historical reasons) After you install new
programs, you have to give the 'rehash' command for tcsh to pick them
up. See 'rehash' in the tcsh manual page, tcsh(1).

Roland

Never ran rehash... actually I tried looking it up but really didn't get
much information - somebody was using "rehash" in a posting about how to
install flashplugin on FBSD 7.1... and it was not clear to me if he
meant that one should be issuing the command or if he was alluding to
the instructions he was using as "same instructions" interspersed with
code snippets.

Now back to the updating - deinstall, reinstall, I mean. :-)
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: Windows Xp crash
    ... The Bios is not showing any hard drives. ... Message came up "Disk Boot failure.: ... I tried about a week ago to install Windows 7 on the second hard ...
    (microsoft.public.windowsxp.hardware)
  • Re: Windows Xp crash
    ... Message came up "Disk Boot failure.: ... indicated that all drives had no disk inserted. ... I tried about a week ago to install Windows 7 on the second hard ...
    (microsoft.public.windowsxp.hardware)
  • Re: ubuntu-users Digest, Vol 56, Issue 402
    ... Play With Ubuntu, Now Mac Won't Boot! ... openoffice3..deb and install it). ... thanks for letting me change the magnetic patterns on your hard disk. ... Play With Ubuntu, Now Mac Won't Boot! ...
    (Ubuntu)
  • Re: Boot Problem
    ... Was either disk set up as a Microsoft dynamic disk? ... Do not change the boot sector signature. ... I ensure all OK by swapping over drives. ... installing XP as it insisted there was no drive to install itself on! ...
    (microsoft.public.windowsxp.hardware)
  • Re: Windows Xp crash
    ... Message came up "Disk Boot failure.: ... indicated that all drives had no disk inserted. ... I tried about a week ago to install Windows 7 on the second hard ...
    (microsoft.public.windowsxp.hardware)