pgp5-filter-5.3.2, php5-imap-5.3.2, php-extensions-1.4



There have been several updates to php, php-extensions and php5-*
My php is now 5.3.2, most of my php5-* also 5.3.2, but
a portupgrade didn't want to upgrade php5-filter and php-imap (errors)
of php-extensions. They stayed version 5.2.12, 5.2.12 and 1.3 respectively.
I did
# pkg_delete -f php5-filter-5.2.12
# pkg_delete -f php5-imap-5.2.12
# pkg_delete -f php_extensions-1.3
and several pkgdb -F until it reported everything OK

Yet still, I can't compile php5-filter-5.3.2, nor php5-imap-5.3.2 or
php-extensions-1.4 (which
depends on these)

How to fix it?

This is what I get
-----
cc -I. -I/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter
-DPHP_ATOM_IN
C -I/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/include
-I/usr/por
ts/security/php5-filter/work/php-5.3.2/ext/filter/main
-I/usr/ports/security/php
5-filter/work/php-5.3.2/ext/filter -I/usr/local/include/php
-I/usr/local/include
/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend
-I/usr/loc
al/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -O2
-pi
pe -fno-strict-aliasing -c
/usr/ports/security/php5-filter/work/php-5.3.2/ext/fi
lter/logical_filters.c -fPIC -DPIC -o .libs/logical_filters.o
In file included from
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/
logical_filters.c:25:
/usr/local/include/php/ext/pcre/php_pcre.h:29:18: error: pcre.h: No such
file or
directory
In file included from
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/
logical_filters.c:25:
/usr/local/include/php/ext/pcre/php_pcre.h:37: error: expected '=', ',',
';', 'a
sm' or '__attribute__' before '*' token
/usr/local/include/php/ext/pcre/php_pcre.h:38: error: expected '=', ',',
';', 'a
sm' or '__attribute__' before '*' token
/usr/local/include/php/ext/pcre/php_pcre.h:44: error: expected
specifier-qualifi
er-list before 'pcre'
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:
In
function 'php_filter_validate_regexp':
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:412:
error: 'pcre' undeclared (first use in this function)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:412:
error: (Each undeclared identifier is reported only once
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:412:
error: for each function it appears in.)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:412:
error: 're' undeclared (first use in this function)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:413:
error: 'pcre_extra' undeclared (first use in this function)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:
In
function 'php_filter_validate_email':
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:500:
error: 'pcre' undeclared (first use in this function)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:500:
error: 're' undeclared (first use in this function)
/usr/ports/security/php5-filter/work/php-5.3.2/ext/filter/logical_filters.c:501:
error: 'pcre_extra' undeclared (first use in this function)
*** Error code 1
1 error
*** Error code 1
Stop in /usr/ports/security/php5-filter.
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"