using TTF fonts in X



I have a folder with a bunch of TTF fonts.
when I run mkfontdir the fonts.dir file is just a "0"
and when I run xset +fp . I get
% xset +fp .
xset: bad font path element (#23), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
% cat fonts.dir
0
% ls -laod . fonts.dir
drwxr-xr-x 2 eitan eitan - 14336 May 23 18:54:55 2010 ./
-rw-r--r-- 1 eitan eitan - 2 May 23 18:55:32 2010 fonts.dir

--
Eitan Adler
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: How add a path to fonts to xset?
    ... Directory missing fonts.dir ... Incorrect font server address or syntax ... Now, xset does not complain, but when trying to run ... Mathematica in graphical mode, ...
    (Fedora)
  • Re: trying to use Font Server on Solaris 10
    ... xset: bad font path element, ... Directory missing fonts.dir ... Incorrect font server address or syntax ...
    (comp.unix.solaris)
  • Re: questions about xset
    ... xset fp rehash ... Font Path: ... I know the Mathematica fonts are neither in my path on my Mac nor on the ... The X font server on your Mac should have a config file. ...
    (RedHat)
  • Re: How add a path to fonts to xset?
    ... Directory missing fonts.dir ... Incorrect font server address or syntax ... Well, since F8 or F9, the X font server isn't installed or enabled by ... And in any case xset still works (i.e. the X server ...
    (Fedora)
  • Re: questions about xset
    ... We have Mathematica 7.0 installed on our computer cluster, ... Incorrect font server address or syntax ... Font Installation ... Be sure to execute xset fp rehash to make the fonts available to the local X ...
    (RedHat)