Re: Help! Can't delete files ...



On Wed, 19 Oct 2011 21:32:39 +0200, Andy Wodfer wrote:
On Wed, Oct 19, 2011 at 9:04 PM, Robert Bonomi <bonomi@xxxxxxxxxxxxxxxxx>wrote:

A) learn to use wildcards.


I know how to use wildcards, but I forgot to tell in my first email that
there are 4 files that have almost the same filenames, so I couldn't do it
this way.

In this case, try to use a terminal emulator which does
have support for UTF-8 both on input and on output. Make
sure your charsets are configured properly. With this
preparation, you should (1st) see the correct file names
in your native language and (2nd) be able to enter (or
complete) their filenames as desired on the command line.



B) learn to use the '-i' option to rm
C) learn to use 'echo' to 'test' filename expansions.


Thanks! Very useful info.

I may add:

D) Learn to avoid non-ASCII characters in filenames (just
like whitespaces and "special" characters).

I'm following this rule for my entire "IT career" now and
I'm very pleased by the results. :-)




--
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...
_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"