Re: X libraries missing



2012-01-28 10:31, Conrad J. Sabatier skrev:
On Sat, 28 Jan 2012 08:15:27 +0100
Bernt Hansson<bah@xxxxxxxxxxxxxxx> wrote:

2012-01-28 08:06, Adam Vande More skrev:
On Sat, Jan 28, 2012 at 12:28 AM, Bernt
Hansson<bah@xxxxxxxxxxxxxxx> wrote:

Hello list!


Trying to update multimedia/audacious-plugins to some other
version 3x.

The problem seems to be ! multimedia/audacious-plugins
(audacious-plugins-2.5.4_2) (X libraries missing)

The error is:

Entering directory aosd.
In file included from ghosd.c:21:
/usr/local/include/X11/**extensions/Xcomposite.h:49:35: error:
X11/extensions/Xfixes.h: No such file or directory
Successfully generated dependencies.
Successfully compiled aosd.c (plugin).
Successfully compiled aosd_osd.c (plugin).
Successfully compiled aosd_style.c (plugin).
Successfully compiled aosd_trigger.c (plugin).
Successfully compiled aosd_ui.c (plugin).
Successfully compiled aosd_cfg.c (plugin).
In file included from ghosd.c:21:
/usr/local/include/X11/**extensions/Xcomposite.h:49:35: error:
X11/extensions/Xfixes.h: No such file or directory
In file included from ghosd.c:21:
/usr/local/include/X11/**extensions/Xcomposite.h:86: error:
expected '=', ',', ';', 'asm' or '__attribute__' before '**
XCompositeCreateRegionFromBord**erClip'
Failed to compile ghosd.c (plugin)!
gmake[5]: *** [ghosd.plugin.o] Error 1
gmake[4]: *** [all] Error 2
gmake[3]: *** [subdirs] Error 1
gmake[2]: *** [all] Error 2
gmake[1]: *** [subdirs] Error 1
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/home/bernt/disk8/ports/**multimedia/audacious-plugins.
*** Error code 1

Stop in /usr/home/bernt/disk8/ports/**multimedia/audacious-plugins.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade20120128-**26744-6ymwm0-0 env
UPGRADE_TOOL=portupgrade UPGRADE_PORT=audacious-**plugins-2.5.4_2
UPGRADE_PORT_VER=2.5.4_2 make DEPENDS_TARGET=package
** Fix the problem and try again.

But I have xorg libraries installed, xorg-libraries-7.5.1


/usr/ports/x11/libXcomposite

Did not work!

You also need x11/libXfixes.

Save yourself some headaches and just do "portmaster libX". That'll
make sure all of them are up-to-date.

Did you recently upgrade your xorg-server? If so, updating libX* and
xf86* is a *must*.

Thank's for the reply.

I got frustrated and did a pkg_delete \*

Now I can't build any port, tried python
cc -c -fno-strict-aliasing -O2 -pipe -fno-strict-aliasing -DNDEBUG -O2 -pipe -fno-strict-aliasing -I. -IInclude -I./../Include -fPIC -DPy_BUILD_CORE -o Modules/python.o ./../Modules/python.c
cc -pthread -Wl,--export-dynamic -o python Modules/python.o -L. -lpython2.7 -lutil -lm
cc -c -fno-strict-aliasing -O2 -pipe -fno-strict-aliasing -DNDEBUG -O2 -pipe -fno-strict-aliasing -I. -IInclude -I./../Include -DPy_BUILD_CORE -o Modules/python.o ./../Modules/python.c
install -o root -g wheel -m 444 ./../Tools/gdb/libpython.py python-gdb.py
[: not found <<< this error pops up with any port
ã²çW?: not found <<< same with this one
install: 1: Syntax error: word unexpected (expecting ")")
install: 5: Syntax error: Error in command substitution
*** Error code 2
1 error
*** Error code 1

Stop in /usr/home/bernt/disk8/ports/lang/python27.
*** Error code 1

Stop in /usr/home/bernt/disk8/ports/lang/python27.
*** Error code 1

Stop in /usr/home/bernt/disk8/ports/lang/python.

I get the same error after a portsnap 20120128 15:30 CET

_______________________________________________
freebsd-questions@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: X libraries missing
    ... Trying to update multimedia/audacious-plugins to some other version 3x. ... (X libraries missing) ... Entering directory aosd. ... *** Error code 1 ...
    (freebsd-questions)
  • Re: X libraries missing
    ... Trying to update multimedia/audacious-plugins to some other ... (X libraries missing) ... *** Error code 1 ... 'XCompositeCreateRegionFromBorderClip' Xcomposite.c:319: error: ...
    (freebsd-questions)
  • Re: X libraries missing
    ... Bernt Hansson wrote: ... Trying to update multimedia/audacious-plugins to some other ... *** Error code 1 ... Save yourself some headaches and just do "portmaster libX". ...
    (freebsd-questions)