Re: iwi0: could not load firmware



Oliver Peter wrote:
% uname -srm
FreeBSD 7.0-BETA1 i386

What did I do wrong?

dmesg output:
iwi0: <Intel(R) PRO/Wireless 2200BG> mem 0xa0202000-0xa0202fff irq 11 at device 2.0 on pci4
iwi0: Ethernet address: 00:16:6f:c3:e3:48
iwi0: [ITHREAD]
iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (iwi_bss_fw, 0xc4c535a0, 0) error 1
firmware_get: failed to load firmware image iwi_bss
iwi0: could not load firmware

I tried to bring up the interface with

# ifconfig iwi0 up

And I have the following entry in /boot/loader.conf

# intel/wireless
set legal.intel_iwi.license_ack=1
if_iwi_load="YES
Shouldn't that be:

legal.intel_iwi.license_ack=1
if_iwi_load="YES"

Guy

--
Guy Helmer, Ph.D.
Chief System Architect
Palisade Systems, Inc.

_______________________________________________
freebsd-stable@xxxxxxxxxxx mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "freebsd-stable-unsubscribe@xxxxxxxxxxx"



Relevant Pages

  • Re: iwi driver
    ... the iwi driver does not work: ... failed to load firmware image iwi_bss ... iwi0: could not load firmware ... If all iwi0 settings are done with only one ifconfig call, ...
    (freebsd-current)
  • Re: iwi driver
    ... the iwi driver does not work: ... failed to load firmware image iwi_bss ... iwi0: could not load firmware ... Most of the time a few ifconfig iwi0 down/up runs get it ...
    (freebsd-current)
  • iwi0: could not load firmware
    ... failed to load firmware image iwi_bss ... iwi0: could not load firmware ... This is my current kldstat-output: ...
    (freebsd-stable)
  • iwi driver
    ... the iwi driver does not work: ... failed to load firmware image iwi_bss ... iwi0: could not load firmware ... device = 'PRO/Wireless 2200BG Network Connection' ...
    (freebsd-current)
  • Re: iwi(4) in RELENG_6
    ... You will still need to load the firmware blobs as modules, ... failed to load firmware image iwi_bss ... nobody there had any suggestions. ...
    (freebsd-stable)